"New PM!" flag doesn't disappear after reading

Service: Eve Community

"New PM!" flag doesn't disappear after reading

Service: Eve Community

I have several users experiencing this problem, however I am unable to reproduce this myself.   Our host is oldgmctrucks.infopop.cc .

The initial reporter is a frequent experienced PM user, so he understands how the system works.  Since last week (likely Friday, he believes), he finds that if he gets the "New PM!" flag and reads the message, the flag does not disappear.  This continues across different signons.  He also has used Ctrl-F5 with no effect.  His platform is Windows 7 using a Firefox Browser.

My experience is as it should be.  I also run Windows 7 on my usual machine, using either IE or Firefox.  It worked on IE and Firefox 43.0.4, and I upgraded to 44.0 today and it works properly there, too.  I believe 44.0 was made generally available yesterday, Jan 26.

I would think that this problem would be consistent for all users, as I believe that the record of the read of a PM is kept on your host.  Some  information is kept in cookies, but this feature remembers on different computers or platforms, so it must be host based.  That would imply that the client machine is immaterial, however not all users experience this problem.  Odd?

Can you offer any insight or suggestions?

Thanks, Neil

Original Post

Activity Stream

Topic Assigned

This topic has been assigned to Dave Dreezer by Dave Dreezer.

Hi Neil,

It actually is cookie based. And sometimes they just get "stuck".  That usually just means a cookie got larger than the browser will accept or check.

The thing to have him do is tell him to enter his profile, click Go ->Personal Zone -> Cookies (might have to click "more" to see the cookies link) and click on "Cookies" on the left hand menu.  Have him click number 2, to delete all cookies from this domain.  Log out, log in and that will reset the PM indicator. 

Usually when the PM indicator is wrong then the light bulbs that indicate new posts in a forum is also wrong. Not always, but usually. Deleting the cookies will also reset all the new posts indicators as well. Initially everything will be marked unread, but as he clicks around and reads things they will catch up.

Thanks, Dave.  I had forgotten about the Cookies page at the bottom of the Personal Zone.

I asked the user to try that, and his response was, "OK, did that and it still shows the same 2 as unread and the indicator flashing.  ???????????".  I replied, asking him to confirm that he had actually also reread those PMs, but I haven't received a reply yet. 

I have another user with the same problem who often appears around midnight.  If I don't hear back from user 1 later today, I will ask user 2 to give it a try also.

Cheers! ...Neil

 

Dave,

User 1 confirmed that even though he had revisited the PMs, the PM flag was still flashing.  

I would rather not involve user 2, as he is not computer literate, he only logs on occasionally, and usually around midnight. 

I'm not sure what the best plan is now.  Perhaps get the user to change his password, let me log on, and see how it behaves for me?  He could reset his password when I am done.  My machine(s) has always behaved correctly.  If this situation acts normally for me, then there is something wrong with his machine.  If I have no success, then I would suspect that there is something odd with this PM on your host.   Without this determination of where the problem lies, I imagine spending much effort trying to analyze the client machine.

Maybe you have a more appropriate suggestion.  Thx.

...Neil

Hi Neil,

I don't know of a better way to follow up than what you have suggested. Checking it with a different browser on the same machine would work as well as him sharing the password with you, if he has access to a different one.  Firefox, Chrome, Opera, (I.E., edge) all store the cookies differently.

One other thought that comes to mind, if the day/date/time on his computer is wrong that will also present this issue. 

Dave,

I don't like this ending to problem. With no positive action, it just "went away" for both users.

One user tried resetting the cookies on Firefox, as well as using a totally different browser that he hadn't used for this site before.  The problem still existed on Saturday. We were going to connect online on Sunday so I could log on to his id and poke around with the systems that I have lying around.  By the time we got together, his problem had disappeared.

Likewise, with the other user on Chrome.  He tried resetting cookies, and such.  By Sunday morning, the problem was gone for him, as well.

Neither of these users shared the same PM(s) that were causing the problem.  

I guess we might as well close this problem.  It isn't really fixed or resolved, but without knowing the conditions that caused it and fixed it, we could wait another decade before we see it again.  I don't know if we have seen this before...it hasn't been reported and nobody posted to the initial problem discussion that they had encountered it also.  I guess it's just one of those random problems that pass over every help desk that I have ever been involved with!

Cheers!

...Neil

 

Hi Neil,

Glad it went away, and sorry that the answer wasn't as clear as we would hope for.  Clearing the cookies has always been the answer for broken topic read indicators or PM alerts. Guess we'll chalk this one up to Gremlins.  

Issue Resolved

This action was taken by Dave Dreezer.
To follow up on this issue, please click here.
×
×
×
×
×