Can't make an image a link

Service: Hoop.la

Can't make an image a link

Service: Hoop.la

Hi,

I think this is a new issue since the latest update earlier this week.

I frequently add images to posts and make the images clickable as a link.

Now

  1. I have to edit the html  directly
    OR
  2. add some text above and below the image,
    and then
  3. select the text and the image and the text,
    and THEN
  4. when I insert a link, the OK button works.

ST

Attachments

Photos (1)
Original Post

Activity Stream

Hi ST-

I just tested and it worked fine for me, using the WYSIWYG editor (without having to edit HTML directly).  Can you tell me what browser you are using, though, so I make sure I am replicating your scenario as closely as possible?  I tested with Chrome.

Other possible explanations-- poor internet connection (maybe the page did not finish loading properly), other javascript you added to your site could be causing a conflict.

One other question, can you clarify how you are adding the images in the first place. I assume you are using the "insert image" button in the WYSIWYG (rather than adding as attachments)?

Hi Ted,

I'm using Firefox, same as usual.

I'm copy/pasting the image straight into the editor. Like this.

and right now, I can't make the image clickable as a link. I'm quite certain that I was fine with this before the update. I do this several times a day.

I'll come back and try with Chrome.

ST

Attachments

Photos (1)

Let's try this.

Time I copied the URL of the image from the previous post.

https://www.socialstrata.com/f...ge/true/mceclip0.png

Then I clicked the picture icon  and pasted the url into the dialog box.

That displayed the image in the WYSIWIG editor. 

Then I selected the image and clicked the link button, and filled in a URL.

I can click the button but nothing happens.

What are we doing differently?

ST

Attachments

Photos (2)

Hi ST,

I'm not seeing any issues with this process, either. It appears to be working fine both on our site and your site in testing. Is it possible you have any browser extensions that could be interfering? I would suggest you check your browser's console to see if there are any errors during the process.

One note: I did see you have a console.log output in your custom JavaScript in the setGroup() helper function (probably for testing at one point). You may want to remove that. It's unlikely that is related (especially since you are experiencing the same issue here on our site), but in general, you will want to avoid console.log output in production environments (to avoid errors in browsers where the console isn't defined):

console.log("sessionStorage.group =" +sessionStorage.group);

Hope that helps!

Brian

Hi Brian,

Thanks for spotting those old console.log entries.

Now here's the really weird thing.  I pulled out my laptop (Surface Book) and did my usual

  • paste an image
  • select the image
  • ctrl-k
  • fill in the URL
  • click Ok

It worked just fine.

Did exactly the same thing on my new computer (Surface Studio) 

  • paste an image
  • select the image
  • ctrl-k
  • fill in the URL
  • click Ok

Nothing happens when I click Okay.

I got the Surface Studio on Thursday last week. That's why I thought the issue arose around the same time as your latest Hoop.la update.

Differences:

Surface Studio

  • Firefox 53.0 32 bit
  • Chrome 58.03.3029.81 64 bit

 

Surface Book

  • Firefox 52.0 32 bit
  • Chrome 57.0.2987.133 64 bit

 

Both are running Windows Version 1703 (OS Build 15063.138)

Okay - (oh no!)

Image result for mister bill snl oh no

 

I just updated Firefox on the Surface Book to Firefox 53.0 32 bit. (same as the Surface Studio).

Now it's doing the same thing (no response to the Ok button)

And to test the premise further, I updated Chrome to Version 58.0.3029.81 (64-bit) (same as the Surface Studio).

It's doing the same thing (no response to the Ok button)

 

Any ideas Brian?

ST

Hello ST,

I was able to reproduce your issues with the latest version of FireFox and Chrome. I was actually on the previous version when I started, and both were behaving correctly, then after the upgrade to the latest version they are both behaving exactly as you have outlined.

We will post back when we have a fix in place.

Thanks for the report and helping us track this down,

Jonmark

Issue In Progress

This action was taken by Jonmark Weber.

Issue Resolved

This action was taken by Brian Lenz.
To follow up on this issue, please click here.
×
×
×
×
×